Technology weblog

IT-Essence
Friday Dec 15, 2006

Gentoo Linux: Installing a masked package

Suppose Gentoo Linux ships with my-package-1.1.4, but you want the most recent (but still masked) version, let's assume my-package-1.1.6 for the moment. How do we configure this?

For example, take the Maven binary package Maven 2.0.2, which is broken for a remote site deploy. To get the most recent version (Maven 2.0.4), add

dev-java/maven-bin ~x86

to the /etc/portage/package.keywords file, or even better execute

echo "dev-java/maven-bin ~x86" >> /etc/portage/package.keywords.

The latter makes sure that adding the package is successful, even if the package.keywords file did not exist yet.

Comments:

Post a Comment:
Comments are closed for this entry.

Hire us
Archives
Tags
Links
Stats
Referrers